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기본 툴 바 

 새로운 SQL Edit 창을 현재 활성 연결에서 열어줍니다 

 새로운 Schema Browser 창을 현재 활성 연결에서 열어줍니다 

 새로운 Procedure Edit 창을 현재 활성 연결에서 열어줍니다 

 새로운 SQL Modeler 창을 현재 활성 연결에서 열어줍니다 

 새로운 Explain Plan 창을 현재 활성 연결에서 열어줍니다 

 새로운 DBMS Output 창을 현재 활성 연결에서 열어줍니다 

 새로운 Object Search 창을 현재 활성 연결에서 열어줍니다 

 Save all Options은 대개 TOAD 종료 시, 저장합니다  

 TOAD Reports를 열어줍니다 

 새로운 Offline Text Editor 창을 열어줍니다(Oracle 연결이 필요하지 않습니다) 

 Toggle PL/SQL Profiling On/Off 

 Toggle Compiling with Debug 

 Configure TOAD Options 

 Integrated Tools 

 Run Script 

 Configure/Execute External Tools 

 Project Manager 창을 열어줍니다 

 Commit any changes to this schema 

 Rollback any changes to this schema 

 

Show windows by connection는 선택되지않은 MDI 자식 창을(child window) 

최소화하고 선택된 Oracle 연결에 대한 MDI 자식 창을 저장합니다.  

 Open a new Oracle connection to the database 
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프로젝트 매니저(Project Manager) 

 
프로젝트 매니저에서는 하나의 중앙 창을 통해 일반적인 DB 작업을 수행할 수 있습니다.  

프로젝트 노드 추가하기 

오른쪽 클릭하고 Add > Project를 선택 또는 Add Item 드롭다운에서 Project를 선택합니다 

폴더 추가하기 Add a Folder  

오른쪽 클릭하고 Add > Folder를 선택 또는 Add Item 드롭다운에서 Folder를 선택합니다.   

복사(Copy) 기능을 통해 사용자는 하나 이상의 프로젝트를 같은 파일이나 FTP 연결, 또는 

스키마에 대한 연결을 통해 즉시 열 수 있습니다. 이 기능은 스키마, 폴더, FTP 폴더 중에서 두 

번째 단계의 노드에 적용됩니다. 

노드를 복사하는 방법 

1 복사하려는 노드를 선택합니다(<Shift>나 <Ctrl>을 누르면 여러 개를 선택할 수 있습니다.) 

2 오른쪽 클릭하고 메뉴에서 Copy를 선택합니다. 

Destination Projects 창이 표시됩니다. 

3 복사하고자 하는 프로젝트를 선택합니다. 

4 Ok를 클릭합니다. 

 

 

SQL 편집기(SQL Editor) 

SQL Editor에서는 입력과 편집, 실행과 튜닝을 할 수 있습니다. TOAD를 

실행하면 사용자는 SQL Edit 창을 처음으로 접하게 됩니다. SQL Edit 창에는 

두 개의 패널이 있습니다. 상단의 패널과 하단의 패널인 결과 패널은 인출된 

데이터를 표시합니다. 결과 패널은 Data, Explain Plan, Auto Trace, DBMS 

Output과 Script Output 탭으로 구성됩니다. 만약 사용자가 옵션인 
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PL/Formatter를 선택했다면 Code Statistics에 대한 탭이 패널에 포함됩니다. 

편집기와 결과 패널 사이의 수평 스플리터(horizontal splitter)를 통해 각 구성 

요소의 사이즈를 설정할 수 있습니다. 

SQL Editor Toolbar 버튼 

 완성되거나 강조된 실행문을 실행합니다. 

 커서에서 실행문을 실행합니다. 

 스크립트로 현재 창을 모두 실행합니다. 

 Previous SQL 실행문을 재호출합니다. 

 Personal SQL 실행문을 재호출합니다. 

 편집할 수 있는 SQL 결과 그리드에 열을 삽입합니다. 

 SQL 결과 그리드에서 현재의 데이터 열을 삭제합니다. 

 데이터베이스에 대한(커밋은 아님!) SQL 결과 그리드 편집을 업데이트합니다. 

 아직 포스트되지 않은 현재 쿼리에 대한 변경을 되돌립니다. 

 SQL 편집기로 파일을 불러옵니다. 

 현재 편집 내용을 저장하기 위해 파일을 명시합니다. 

 파일을 저장합니다. 

 현재의 SQL 실행문을 가져와서 개발 도구 코드 실행문을 작성합니다. 

 개발 도구 코드 실행문을 가져와서 Oracle SQL 실행문의 외부로 strip 합니다. 

 현재 실행문에 대한 Explain Plan을 실행합니다. 

 선택된 SQL 문을 SQLab Xpert 모듈로 튜닝합니다.  

 이 창에서 사용 중인 세션을 변경합니다.   

 

 



 - 5 - 

바로 가기 키 

F1 

F1을 누르면 도움말 파일이 표시됩니다. 

<ALT><UP>와  <ALT><DOWN>는 SQL 히스토리를 스크롤합니다.  

몇 가지 알아둘 키 

F4 

팝업 메뉴에서 오브젝트를 보여줍니다(테이블, 뷰, 프로시저, 함수, 또는 패키지). 

Procedure Editor 또는 SQL Editor에서 테이블, 프로시저, 함수, 패키지나 뷰의 이름 위에 

커서를 놓고 F4를 누르면 Object Describe 창에 액세스할 수 있습니다. 대응하는 

오브젝트 유형에 대하여 Object Describe 창은 Schema Browser 창과 유사합니다. 

F6 

SQL Editor와 결과 패널 사이에 커서를 토글합니다. 

F10 

커서가 위치한 섹션에(편집기와 결과 패널) 대한 오른쪽 클릭 메뉴를 표시합니다. 

<CTRL>T 

행 드롭다운 ?  테이블 이름 위에 커서를 놓으면, 테이블에서 행을 목록으로 보여줍니다. 

<ALT><UP> 

사용자가 실행해 온, 이전에 실행된 실행문으로 이동  

 

<ALT><DOWN>  

가장 최근 실행한 실행문으로 이동합니다. 

<HOME>  

라인의 맨 처음으로 이동합니다. 

<CTRL><HOME>  

편집기의 맨 위로 이동합니다. 데이터 그리드에서는 커서가 위치한 행의 첫 번째 열로 

이동합니다. 
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<END> 

라인의 맨 끝으로 이동합니다. 

<CTRL><END>  

사용자가 실행 중인 행의 마지막 열로 이동합니다. 

주의: <CTRL><END>를 사용하면 TOAD는 모든 사항을 인출하게 되어 프로세스가 

길어집니다. 

대형 레코드셋의 끝에서 열을 시험할 필요가 있다면 쿼리를 다음과 같이 

세분하시기(refine) 바랍니다. 

Select * from table  Where primary_key > value 

 

키스트록 
(KEYSTROKE) 

기능  

F1 TOAD 도움말 파일에서 SQL Editor 부분을 보여줍니다. 

F2 
전체 스크린 Editor와 Editor/Results Panel 표시 장치 사이를 
토글합니다. 

<SHIFT>F2 전체 스크린 그리드를 토글합니다. 

F3 다음 어커런스를 찾아줍니다. 

<SHIFT>F3 이전 어커런스를 찾아줍니다. 

F4 팝업 창에서 테이블, 뷰, 프로시저, 함수, 또는 패키지를 보여줍니다. 

F5 스크립트로 실행합니다. 

F6 Editor와 Results Panel 사이에 커서를 토글합니다. 

F7 모든 텍스트를 지웁니다. 

F8 
이전의 SQL 실행문을 재호출합니다.(SQL Statement Recall 창을 
불러옵니다) 

F9 실행문을 실행합니다. 

<CTRL>F9 실행 없이(구문 분석) 실행문을 검사합니다. 

<SHIFT>F9 커서에서 현재 실행문을 실행합니다. 

F10 오른쪽 클릭 메뉴를 표시합니다. 

F12 편집기 내용을 특정한 외부 편집기로 전달합니다. 

<CTRL>A 모든 텍스트 선택 

<CTRL>C 복사 

<CTRL>D Procedure Arguments를 보여줍니다. 
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<CTRL>E 현재 실행문에서 Execute Explain Plan을 실행합니다. 

<CTRL>F 텍스트를 찾아줍니다.(Find Text 창을 불러옵니다) 

<CTRL>G 라인으로 이동합니다.(Goto Line 창을 불러옵니다) 

<CTRL>L 텍스트를 소문자로 변환합니다. 

<CTRL>M 코드 실행문(Code Statement)을 만듭니다. 

<CTRL>N 
Named SQL Statement를 재호출합니다.(SQL Statement Recall 창을 
불러옵니다) 

<CTRL>O 텍스트 파일을 열어줍니다. 

<CTRL>P 코드 실행문을 스트립합니다. 

<CTRL>R 검색과 대체(Find and Replace Text 창을 불러옵니다) 

<CTRL>S 파일 저장 

<SHIFT><CTRL>S 다른 이름으로 저장 

<CTRL>T 행 드롭다운을 표시합니다. 

<CTRL>U 텍스트를 대문자로 변환합니다. 

<CTRL>V 붙이기 

<CTRL>X 자르기 

<SHIFT><CTRL>Z 마지막으로 취소한 작업을 재실행합니다. 

<ALT><UP> 이전 실행문을 표시합니다. 

<ALT><DOWN> 다음 실행문을 표시합니다(<ALT><UP> 사용) 

<CTRL><HOME>  
데이터 그리드에서는 맨 위의 레코드셋으로 이동하며, 결과 그리드에서는 
커서가 위치한 행의 첫 번째 열로 이동하고, 편집기에서는 텍스트의 첫 
번째 열과 첫 번째 행으로 이동합니다. 

<CTRL><END> 
데이터 그리드에서는 레코드셋의 맨 끝으로 이동하며, 
편집기에서는 텍스트의 마지막 열과 마지막 행으로 이동합니다. 
이 절의 40페이지에서 주의 사항을 참조하십시오. 

<CTRL><SPACE> 코드 완성 템플릿을 활성화합니다. 

<CTRL><TAB> MDI Child 창의 콜렉션을 순환합니다. 

<CTRL><ENTER> 커서에 있는 현재 SQL 실행문을 실행합니다. 

<CTRL>. (마침표) 테이블명을 자동으로 완성해줍니다. 
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SQL Editor 사용법 

Select dept.rowid, dept.* from dept 

<CTRL><ENTER> 또는 F9를 눌러 실행한다면, 데이터를 편집할 수 있습니다. 

더불어 View > Options > Data Grids- Data에서 Show ROWID를 선택하여 

ROWID가 결과에 표시되어야 합니다.  

다른 방법으로는, TOAD EDIT 명령을 입력하여 ROWID 행에서 SELECT SQL 

실행문으로 명령을 번역할 수 있습니다.  

Edit dept 

그리고 <CTRL><ENTER> 또는 F9를 눌러 실행합니다. 그러면 데이터를 

편집할 수 있습니다. 

스크린의 맨 밑에 상태 패널 지시기가 녹색으로 변했는지 확인하십시오. 

녹색으로 변했다면 테이블 데이터를 편집할 수 있습니다. 지시기가 적색이라면, 

데이터는 편집할 수 없지만 선택과 복사는 가능합니다. 

상태 패널 지시기: 녹색=편집 가능 적색=편집 불가능 

 

단일 레코드 뷰(Single Record View) 

Single Record View 버튼은 TOAD 데이터 창과 결과 그리드에 모두 

표시됩니다. 이 버튼은 테이블 좌측 상단에 위치합니다.  

 

 

 

Single Record View 버튼을 클릭하면 Single Record View 창이 사용자가 

선택한 항목의 레코드를 표시합니다. 창의 화살표 버튼을 통해 행의 위 아래를 

이동할 수 있습니다. 또한 레코드를 삽입하고 삭제하며 편집할 수 있습니다. 
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Explain Plan 

TOADPREP.SQL의 로드와 실행 

1 SYS 또는 SYSTEM 스키마나 DBA 역할의 스키마에 연결합니다. 

2 File > Open File을 엽니다 

3 사용자의TOAD > TEMPS 폴더를 열어 줍니다. 

4 TOADPREP.SQL에서 더블클릭합니다. 

5 TOADPREP.SQL를 사용자의 SQL Editor로 불러옵니다. 

6 Script 버튼으로 Execute를 클릭합니다. 

 

Explain Plan 실행하기 

1 SQL Script를 SQL Editor로 불러들입니다. 

2 Select, Insert, Update, 또는 Delete 같은 SQL 실행문을 클릭합니다 

3 SQL-Window > Explain Plan Current SQL 메뉴 항목을 선택합니다. 

4 Explain Plan 결과는 결과 그리드에 표시됩니다. 

 

View Explain Plan에 액세스하기 

1 View > Explain Plan 메뉴 항목으로 이동합니다. 

2 Explain Plan 항목을 클릭합니다. 

3 이전의 Explain Plans 목록을 표시합니다. 

모든 실행문은 TOAD의 세션에서 TOAD 폴더 내 SQLS.DAT 파일 안에 

저장됩니다.  
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사용자는 <ALT> <UP> 이나 <ALT> <DOWN>를 눌러서 SQL Editor 편집 

패널 내에 이전 실행문을 직접 스크롤할 수 있습니다.  

 

실행문 실행하기 

실행하려는 단일 실행문이 포함된 SQL Edit 창에서는 

F9를 누릅니다. 또는 툴 바에서 Execute Statement 버튼을 누릅니다. 

 

최소한 하나 이상의 공백 라인으로 분리된 여러 실행문 중에서 단일 

실행문 실행하기 

실행하려는 구문 내에 caret/cursor를 두고 클릭합니다. 그리고 

<SHIFT> F9 또는 <CTRL><ENTER>를 누릅니다. 

또는 툴 바에서 Run Current Statement 버튼을 클릭합니다. 

 

SQL Scripts 실행 

SQL Edit 창은 DDL 실행문과 Insert 실행문 등을 포함하는 SQL 스크립트를 

처리할 수 있습니다. 몇 가지의 SQL*Plus 명령은 TOAD가 SQL 스크립트를 

처리함에 따라 무시됩니다. 다른 SQL*Plus 명령을 포함하는 스크립트에 대해 

사용자는 SQL-Window > Execute SQL Window via SQL*Plus 메뉴 항목을 

사용하여, 여전히 자신의 스크립트를 실행할 수 있습니다.  

 

테이블/별칭 보기 

테이블이나 별칭 보기를 설정하면, 쿼리의 행을 실행하는 바로 가기를 만들 수 

있습니다.  

ALIASES.TXT 파일은 TOAD\TEMPS 디렉토리에 존재하며 다음과 같습니다. 

table_name=alias 

such as: 

AAX_ACCESSGROUP_APPLICATION=aax 
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ACA_ACTIVITY_ACTION=aca  

다음과 같이 간단히 입력할 수 있습니다. 

테이블명 완성 기능(Tablename Completion) 

dep을 입력하고 <CTRL>.을 누르면, dep으로 시작하는 모든 테이블 목록이 

표시됩니다.  

 

편집기 구성 

모든 편집기 파서 스크립트 파일은 TOAD\TEMPS 폴더에 저장됩니다. 

§ 북마크(Bookmarks) 

SQL Editor 내에서 위치를 마크해 두면, 쉽게 해당 라인으로 돌아갈 수 

있습니다. 하나의 편집기에 10개의 북마크를 설정할 수 있습니다.  

북마크 설정 

<CTRL><SHIFT>#를 누르십시오. 여기서 #은 0과 9 사이의 숫자입니다. 

북마크 숫자를 보여주는 작은 녹색 상자가 편집기 여백에 표시됩니다.  

북마크로 빠르게 이동하기 

<CTRL>#를 누르시기 바랍니다. 여기서 #은 이전에 0과 9사이에 정의된 

북마크입니다.  

§ 코드 완성 템플릿(Code Completion Templates) 

코드 템플릿은 Auto Replace Substitution 개념에 바탕을 두고 있지만, 대체 

작업을 수행하기 위해 수동 키스트록(<CTRL><SPACE> )이 필요합니다. 

 [Language]가 HTML, INI, JAVA, PLSQL, 또는 TEXT가 될 수 있는 위치는 

TOAD\TEMPS 폴더의 DCI입니다. 

Editor Options  

Editor Options은 편집기(SQL Edit 또는 Procedure Edit 창)의 오른쪽 클릭 

메뉴 또는 Edit > Editor Options 메뉴 항목을 통해 열 수 있는 팝업 대화 

상자에서 선택과 선택 취소, 변경이 가능합니다.  

Editor Options 의 왼쪽 패널에는 General Options, Highlighting, Key 
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Assignments, Auto Replace, Code Templates의 카테고리가 

표시됩니다. 

 

Key Assignments 

 

Key Assignments 항목을 클릭하면, 해당 Key Assignments 옵션이 표시됩니다. 

목록으로 표시된 Key 명령 카테고리는 다음과 같습니다. 

Bookmarks 

Caret movement 

Clipboard operations 

Deletion operations 

Miscellaneous 

확장 버튼을 클릭하여 카테고리 목록을 확장합니다.  

리스트에서 항목을 선택하면 항목의 키보드 단축키가 Activation 키 시퀀스 

창에 표시됩니다.  
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코드 템플릿(Code Templates) 

Code Templates 항목을 클릭하면 관련 옵션이 표시됩니다. 

 

 

바로 가기/  기술(Shortcut/Description) 창 

정의 추가(Add definition) 

정의 삭제(Delete definition) 

 

오른쪽 클릭 메뉴 

SQL Editor에서 오른쪽 마우스 버튼을 클릭 또는 F10을 눌러서 오른쪽 클릭 

메뉴를 표시할 수 있습니다.  

옵티마이저 모드(Optimizer Mode) 

이 메뉴는 전체 세션에 대한 옵티마이저 모드를 변경합니다. 옵션에는 Choose, 

Default, Rule, First Rows, All Rows가 있습니다.  
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SQL 결과 패널(Results Panel) 

SQL Results Panel에는 Data, Explain Plan, Auto Trace, DBMS, Output, 

Script Output의 다섯 개의 탭이 있습니다. 옵션인 PL/Formatter를 설치한 

경우에는 Code Statistics 탭이 이 패널에 나타납니다. 

데이터 탭(Data tab)  

편집 가능한 데이터 그리드 (Editable Data Grid) 

데이터 그리드는 편집 가능한 SQL 쿼리의 결과를 표시하여, 쿼리가 업데이트 

가능한 결과셋으로 반환되게 합니다. 쿼리문은 반드시 업데이트 가능한 

ROWID를 반환해야 합니다. 예를 들어, 다음은 업데이트가 가능합니다. 

select * from employee 

하지만, 다음은 업데이트가 불가능합니다. 

select employee.*, rowid from employee 

이 문제점을 해결하기 위해, 사용자는 TOAD가 업데이트 가능한 버전의 문으로 

번역할 수 있는 EDIT 항목으로 대체할 수 있습니다. 

예를 들어: 

edit employee 

결과 셋을 편집할 수 있지만, 읽기만 가능한 상태라면 View > Options > Data 

Grid ?  Data > Default to Read-Only 옵션이 선택 해제되었는지 확인하시기 

바랍니다.  

상태 패널에는 레코드 셋이 편집가능한지(녹색), 편집이 불가능한지(빨간색)를 

알려주는 빨간색이나 녹색 상자가 표시됩니다.  

View > Options > Data Grids 탭으로 가서 Popup memo editor on 

double-click 옵션이 선택되어 있는지 확인하시기 바랍니다. 작업을 원활히 

하려면, 이 옵션을 선택해야 합니다.  

Explain Plan tab 

View > Explain Plan를 통해 이전의 Explain Plans를 확인하려면 먼저 

TOADPREP.SQL 스크립트를 실행해야 합니다. 
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Auto Trace tab 

Auto Trace는 자동 추적 모드에서 발행된 모든 실행문의 결과를 표시하여 

튜닝을 도와줍니다. 쿼리를 실행할 때, 사용자는 그 쿼리에 관련된 퍼포먼스 

통계를 확인할 수 있습니다.  

DBMS Output 탭 

사용자가 DBMS Output 문을 선택하면, 결과 그리드의 DBMS Output 탭에는 

DBMS Output가 자동으로 표시됩니다. 

 

 

 

 

Turn Output On/Off, DBMS Output 기능을 키거나 끌 때, DBMS 

Output이 OFF일 때는 빨간색 불이, DBMS Output이 ON일 때는 녹색 

불이 들어옵니다. 

 
Clear window  

 

Set Output Buffer Size, 사용자가 크기를 설정할 수 있는 Set DBMS 

Output 버퍼 창을 불러옵니다. 

 
Save to File 

 
Print Output window 

 

Frequency of polling 

폴링 횟수를 설정할 수 있습니다. (2초에서 15초). 

Open a new DBMS Output 창 버튼을 선택하면, 새 DBMS Output 창을 열 수 

있습니다.  
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Open a new DBMS Output window 

DBMS Output에 대한 내용은 Procedure Editor 장을 참고하십시오. 

Script Output 

스크립트를 실행하면, 그 결과가 이 탭에 자동적으로 표시됩니다. 스크립트로 

실행한 경우, 스크립트는 임시 파일에 저장되지 않기 때문에 사용자는 변경 

작업을 저장하지 않아도 됩니다. 오른쪽 클릭> Print 메뉴 항목을 통해 Script 

Output 탭에서 인쇄 작업을 할 수 있습니다. 

 

SQL 템플릿(SQL Templates) 

SQL Templates(도움말)은 Oracle SQL 함수와 표현에 대한 팝업 등록정보 

입니다. 항목의 관련 텍스트 파일은 TOAD 디렉토리 내, TEMPS 폴더에 

있습니다. 

  

파일명 관련 템플릿 

STRFUNCS.TXT Single Row Character Functions 

NUMFUNCS.TXT Single Row Number Functions 

GRPFUNCS.TXT Group Functions 

DATFUNCS.TXT Date Functions 

DATEFMTS.TXT Date Format Options 

CNVFUNCS.TXT Data Conversion Functions 

MSCFUNCS.TXT Other Misc. Functions 

NMBRFMTS.TXT Number Format Options 

PSEUDO.TXT Oracle Pseudo Columns 

OPTHINTS.TXT SQL Optimizer Hints 

PREDFXCP.TXT Defined Exceptions 

SQL Templates 창에서 항목이
나 함수 표시에 관한 설명은 
하단의 패널에 표시됩니다. 항
목은 사용자의 SQL 스크립트
로 드래그 앤 드롭할 수 있습
니다. 
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USRFUNCS.TXT User Provided Function List  

  

 

 

 

Make Code Statement 및 Strip Code Statement 

SQL Edit 창에는 TOAD에서 SQL 문을 Delphi, VB, C++, Java, Perl 같은 코드 

개발 도구로 복사하거나, 반대로 코드 개발 도구에서 TOAD로 복사하는 작업을 

단순화하는 두 개의 함수가 있습니다. 이 함수는 각각 Make Code Statement 

<CTRL>M 과 Strip Code Statement <CTRL>P입니다. 

코드 개발 도구 선택 

View > Options > SQL Editor 탭 > Make Code Format 드롭다운 목록에서 

코드 개발 도구를 선택할 수 있습니다. 

최근에는 Delphi, VB, C++, Java, Perl을 지원하지만, 기본 선택은 VB 입니다. 

외부 편집기  

SQL Editor 내용을 외부 편집기로 편집할 수 있습니다. TOAD Options > 

Editors > External Editor Command Line을 차례로 불러옵니다. 

c:\winnt\notepad.exe와 같이 드라이브 이름, 경로, 실행 가능한 외부 편집기 

이름을 입력합니다. While in the SQL Editor 또는 Procedure Editor에서 

<CTRL><F12>을 누르면, 외부 편집기를 불러올 수 있으며 현재의 TOAD 

Editor 내용이 로드됩니다.  

 

§ View > Options > Procedure Editor > Reload files when activating 

TOAD if the file time stamp is changed 옵션을 선택한 경우에만 파일의 

내용을 다시 불러올 수 있습니다. 

 

SQL Editor 태스크 

이번 절에서는 사용자가 SQL Editor로 수행하는 다양한 태스크에 대해 

이러한 템플릿은 사용자가 텍스트 파일을 편집하여 구
성할 수 있습니다. 이는 특히 PREDFXCP.TXT와 
USRFUNCS.TXT를 구성하는 데 유용합니다. 
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단계별로 알려줍니다.  

쿼리 수행 시, 테이블 열 찾기 

SYS. SYSTEM 등 다른 스키마의 오브젝트를 포함하여 사용자가 액세스하는 

모든 테이블이나 뷰에 적용되는 기능입니다. 

1 테이블 이름과(또는 뷰 이름) 마침표를 입력하고 <CTRL>T를 누릅니다. 

(또는 몇 초 동안 기다림) 

2 열 목록이 표시됩니다. 

 

 

 

3 선택하려는 항목을 클릭합니다. 1가지 이상의 항목을 선택하려면 <CTRL> 

키를 누른 상태에서 선택하려는 항목을 클릭합니다. 

 

 

 

4 <ENTER> 키를 누르거나 <TAB>을 누릅니다. 

5 그러면 선택한 열이나 행이 SQL Editor 로 넘어가서 쿼리가 작성됩니다. 

 

select table_privileges.TABLE_NAME, 
TABLE_PRIVILEGES.SELECT_PRIV, 
TABLE_PRIVILEGES.INSERT_PRIV 
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테이블 이름을 SQL Editor로 복사 

Table Name Select 대화 상자에서 테이블, 뷰, 동의어 이름을 SQL Editor로 

복사할 수 있습니다.  

 

 편집 툴 바의 Show Tables 창 버튼은 Table Name Select 창을 
엽니다. 

 

 

 

1 편집 툴 바의 SQL Edit 창 또는 Procedure Edit 창에서 Show Tables 창 

버튼을 클릭합니다.  

2 Table Name Select 창이 표시됩니다. 

3 선택하려는 항목을 클릭합니다. 한 가지 이상의 항목을 클릭하려면 

<CTRL> 키를 누르고 선택하려는 항목을 클릭합니다. 

4 항목을 드래그 앤 드롭하거나, <CTRL>C로 복사하고<CTRL>V를 눌러서 

붙여넣습니다 .  

Table Column 이름을 SQL Editor로 복사 

 

 두 번째 SQL Editor와 Procedure Editor에서 Show Columns 버튼은 

Column Name Select 창을 엽니다.  

1 편집 툴 바의 SQL Edit 창 또는 Procedure Edit 창에서 Show Columns 

창 버튼을 선택합니다. 

2 Column Name Select 창이 표시됩니다. 
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3 선택하려는 항목을 클릭합니다. 한 가지 이상의 항목을 선택하려면 

<CTRL> 키를 누른 상태에서 선택 항목을 클릭합니다. 

4 항목을 드래그 앤 드롭하거나, <CTRL>C를 눌러 복사하고 <CTRL>V로 

붙여넣을 수 있습니다. 

 

SQL Editor에서 입력 작업 시 오브젝트의 설명을 보려면 

1 F4를 누릅니다. 

2 오브젝트를 설명하는 팝업 창이 표시됩니다. 

 

 

File > Reopen File 

File > Reopen File 메뉴를 사용하면 파일을 SQL Editor나 Procedure 

Editor에서 열 수 있습니다. 최근에 열었던 파일 10개의 목록이 표시됩니다. 이 
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목록은 TOAD\TEMPS 폴더의 SQLFILES.TXT 파일에 저장 및 재저장됩니다. 

기존 SQL 호출 

 Recall Previous SQL 버튼 

1 SQL-Window > SQL Command Recall 메뉴 항목을 선택합니다. 

F8 또는 Recall Previous SQL 버튼을 누릅니다. 

2 SQL Statement Recall 창이 표시됩니다. 사용자가 최근에 실행했던 

100가지 쿼리의 목록이 SQL Edit 창에 열립니다.  

 

사용자가 작성한 Personal SQL 호출  

 Recall Personal SQL 버튼 

1 쿼리를 실행합니다. 

2 메뉴 항목에서 SQL-Window > Recall Personal SQL를 선택합니다. 

SQL Editor 툴 바에서 Recall Personal SQL 버튼을 선택합니다. 

SQL 실행문 목록은 PERSSQLS.DAT에서 저장, 검색할 수 있습니다. 

Named SQL 실행문 작성과 재호출 

1 메뉴 항목에서 SQL-Window > Add to Named SQLs을 선택합니다. 

2 메뉴 항목에서 SQL-Window > Recall Named SQL를 선택합니다. 

또는 

<CTRL>N을 누릅니다. 

이름이 지정된 SQL 실행문의 목록은 NAMEDSQL.DAT에 저장하고 검색할 수 

있습니다.  
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데이터 그리드(Data Grids) 

오른쪽 클릭 메뉴 

데이터 그리드의 오른쪽 클릭 메뉴에는 다양한 디스플레이, 인쇄, 내보내기 

옵션이 포함됩니다. 

메모 편집기(Memo Editor)  

View > Options > Data Grids > Popup Memo Editor on Double-Click 설정을 

선택한 경우 더블 클릭하여 Memo Edit 팝업 창에서 값을 편집합니다. 

인쇄 그리드 

이번 장 후반부에 다룰 Report Link Designer를 불러옵니다.  

Save Grid Contents 

구분자(Delimiters)  

표준인 콤마를 사용합니다. 데이터를 구분하는 ASCII 표준은 <TAB> 

문자입니다. 

열 순서 재정렬 

1 그리드에서 머리글을 클릭하여 이동할 열을 선택합니다.  

2 열을 왼쪽이나 오른쪽으로 원하는 만큼 끌어다 놓습니다. 

3 열을 재배열한 후에 데이터를 클립보드에 복사하거나 파일에 저장하면 

데이터는 새로운 열 순서에 따라 배열됩니다. 

선택한 열 임시로 숨기기 

1 오른쪽 클릭 메뉴에서 Select Columns 항목을 선택합니다. 

2 숨기고자 하는 열을 선택 해제합니다 

사용자의 넓이 구성에 따라 열 넓이 설정하기 
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열을 단지 확인만 하려면, 

§ 마우스  포인터를 그리드 머리글로 이동하여 두 열 사이의 경계선에 놓고 

좌우로 드래그합니다. 

쿼리의 열이 쿼리마다 동일하다면 TOAD는 사용자 열 넓이를 계속 유지합니다. 

사용자는 WHERE 절이나 ORDER BY 절을 추가하고 쿼리를 재실행할 수 

있으며, 열 넓이를 똑같이 유지할 수 있습니다.  

쿼리의 열이 다르다면, 그리드 열의 크기는 View > Options > Data Grids - 

Visual > Size data to the width of column headers, Size grid columns to the 

width of the data와 Allow columns to be less than the header width 옵션에서 

조절할 수 있습니다. 

데이터 찾기 

1 오른쪽 클릭 메뉴나 기본 Grid menu에서 Find Data를 선택합니다. 

Grid Data Find 창이 표시됩니다. 

2 검색할 키워드와 값을 입력합니다. 

3 ADD 버튼을 클릭합니다. 

4 OK를 클릭합니다. 

 

Duplicate Row 

이 항목에서 사용자는 전체 열을 복사할 수 있습니다. 

행을 복사하여 새 행 작성 

1 레코드 셋을 편집합니다. 

2 복사할 행의 셀을 클릭합니다. 

3 Grid > Copy Row 메뉴 항목을 선택합니다.(오른쪽 클릭 메뉴에서 

액세스할 수 있음) 

4 전체 행을 SQL 결과 그리드 밑에 복사하여 편집할 준비를 합니다.  

주의: 레코드 셋은 Copy Row 함수가 실행되기 전에 편집해야 합니다. 

5 작업을 취소하고 싶다면 <ESC> 키를 누릅니다. 
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Record Count 

레코드 셋에서 레코드 수를 표시하는 메시지 창을 보여줍니다. 레코드 갯수는 

SQL Editor에서 취소할 수 있으며 Schema Browser, Master/Detail Browser, 

SQL Modeler에서 취소할 수 있습니다.  

Set Sequence Field 

Fix Current Column 

Preview Current Column 

Remove Preview Column 

Allow Multi-Select 

Grid Options 

Size Columns 

About Row Height 

 

Sort Options 창 

Sort Options 창에서 사용자는 내림차순이나 오름차순으로 열을 정렬할 수 

있으며 정렬을 제거할 수도 있습니다.  

 
 

Schema Browser와 SQL Editor의 특정한 조건에서 그리드 열 머리글을 

클릭하면 이 창을 열 수 있습니다. Schema Browser에서 필터 버튼을 통해 
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정렬 필터를 적용할 수 없다면, 열 머리글을 클릭하여 Sort Options 창을 

불러올 수 있습니다.  

View > Options > Data Grids ?  Visual > Confirm sorts when clicking on 

column header 옵션이 기본값으로 선택됩니다. 

 

계산기(Calculator) 

 

 

Report Link Designer 

사용자가 그리드에 인쇄 명령을 내리면 (Grid > Print Grid  또는 그리드를 

오른쪽 클릭하여 Print 선택), Report Link Designer가 표시됩니다. 

Options 탭 

Draw Mode 드롭다운 

Bands 

Headers 

Preview 

Autocalculate Preview Lines 

Preview Line Count 스피너 

Grid  
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Nodes Grid  

Colors 탭 

Fixed Transparent 

Grid Line Color 드롭다운 

Fonts 글꼴 

Behaviors 탭 

Miscellaneous 탭 

 

프로시저 편집기(Procedure Editor) 

Procedure Editor에서 프로시저, 함수, 패키지, 트리거, 타입, 형식 본문 등을 

작성하고 수정할 수 있습니다. 옵션인 PL/SQL 디버깅 기능도 포함됩니다. 

오른쪽 마우스 버튼을 클릭하거나 F10을 클릭하면 Set Bookmark와 

Uncomment Block 같은 다양한 옵션이 있는 콘텍스트 메뉴에 액세스할 수 

있습니다.  

Procedure Editor 창을 불러오는 방법 

§ TOAD의 기본 툴 바 버튼을 클릭합니다. 

§ 메뉴 항목의 Database > Procedure Editor를 선택합니다.  

§ Schema Browser > Procedure Editor 페이지에서 Procedure Editor 

버튼을 클릭합니다. 

§ View > Options > Startup 페이지에서 새로운 연결에 대한 Procedure 

Editor to StartUp를 설정합니다. 
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툴 바 버튼(Toolbar Buttons) 

Procedure Editor 툴 바에는 다음과 같은 버튼이 들어 있습니다. 

현재의 완성 실행문을 컴파일합니다. 

다음의 3가지 버튼은 Options 대화 상자의 Procedure Editor 탭에서 Enable 

Compiling Multiple Objects From a Single File 옵션이 선택될 때만 표시됩니다. 

 

 
커서 위치에서 편집기 끝까지 실행합니다 

 
편집기의 처음부터 커서 위치까지 실행합니다. 

 
강조 표시된 실행문을 실행합니다. 

 

 SQL 파일을 Procedure Editor로 불러옵니다. 

드롭다운 방향키는 편집기 창이 열린 동안, 데이터베이스에서 불러온 가장 

최근의 오브젝트를 표시합니다.  

 
내용을 새로운 파일명으로 저장합니다. 

 

현재 편집기 내용을 파일에 저장해주며 사용자가 스크립트를 변경했을 

때만 활성화됩니다. 소스 콘트롤 외부의 파일을 체크합니다. 

 
소스 콘트롤 내부의 파일을 체크합니다. 

 
데이터베이스에서 기존의 오브젝트로부터 소스를 불러옵니다.  

 

드롭다운 방향키는 편집기 창이 열린 동안, 데이터베이스에서 불러 온 가장 

최근의 오브젝트를 표시합니다. 편집기가 닫히면, 목록은 리셋됩니다.  

 

 
데이터베이스 또는 파일로부터 오브젝트를 불러옵니다. 

 
새로운 프로시저, 함수, 패키지, 트리거를 작성합니다. 

 
종속적인 프로시저를 컴파일합니다.(이 프로시저를 호출하는 오브젝트) 
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SQLab Xpert를 사용하여 현재의 실행문을 튜닝합니다. 드롭다운 

목록에는 SQLab Xpert/SQL Impact where used/SQL Impact Quality 

Audit가 포함됩니다. 

 

창의 활동 세션을 변경합니다. 

이 버튼에는 가능한 세션을 보여주는 드롭다운 방향키가 포함됩니다.  

 

 

바로 가기 키(Shortcut Keys) 

바로 가기 키 기능 

F1 Window 도움말 파일 표시 

F2 오류 패널 표시/숨기기 

F3 다음 어커런스 찾기 

F4 팝업 창에 테이블, 뷰, 프로시저, 함수, 패키지를 기술 

F7 모든 텍스트 지우기 

F9 컴파일 

F10 팝업 메뉴 표시 

F12 
SQL 또는 저장된 Procedure Editor 내용을 특정한 외부 
편집기에 전달 

<CTRL>A 모든 텍스트 선택 

<CTRL>C 복사 

<CTRL>D 함수가 사용자에게 반환 데이터 타입을 알려주므로 프로시저 
인자 표시 

<CTRL>F 텍스트 찾기 

<CTRL>G 라인으로 이동 

<CTRL>L 텍스트를 소문자로 변환 

<CTRL>O 텍스트 파일 열기 

<CTRL>R  찾기와 바꾸기 

<CTRL>S 파일 저장 

<SHIFT><CTRL> S 다른 이름으로 저장 

<CTRL>T 행 드롭다운 표시 
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<CTRL>U 텍스트를 대문자로 변환 

<CTRL>V 붙이기 

<CTRL>X 자르기 

<CTRL>Z 마지막 변경 작업 취소 

<SHIFT><CTRL>Z 마지막 취소 작업 재실행 

<CTRL><HOME>  편집기의 1행, 1행으로 이동 

<CTRL><END>  버퍼의 마지막 라인으로 이동 

<CTRL><SPACE> 디스플레이 코드 템플릿을(키 조합+<CTRL> <SPACE>) 적용 

가능한 템플릿에 표시 

<CTRL><TAB>  MDI Child 창의 콜렉션을 순환 

<CTRL><ENTER> 컴파일 

<CTRL>. (마침표) 테이블 이름 자동완성 

 

프로시저 편집기 사용법 

Procedure Edit 창은 SQL Edit 창과 유사합니다.  

Procedure Editor로 코드를 가져오려면 

§ 파일에서 읽습니다. 

§ 데이터베이스에서 기존 오브젝트를 불러옵니다. 

§ 새 Procedure Editor 대화 상자를 작성합니다. 

§ 새로 입력하여 붙여넣습니다. 

§ File Explorer에서 드래그 앤 드롭합니다. 

§ Schema Browser에서 프로시저나 트리거를 선택하고 Procedure Editor 

버튼에서 Load를 클릭합니다(오브젝트 패널의 Procedure Editor Window 

버튼). 

F9 키는 데이터베이스에 코드를 컴파일하고 저장합니다.  
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사용자가 옵션인 PL/SQL Debugger를 갖고 있을 경우, Procedure 

Editor 여백을 클릭하면 정지점(breakpoint)이 작성됩니다. 마우스로 

텍스트를 선택할 때는 텍스트 영역에 셀렉터(selector)를 드래그합니다. 

 

File > Open로 프로시저 열기 

1 Proc Edit 창을 열고 File > Open File으로 이동합니다. 

2 Load File 창이 표시됩니다. 

3 선택 파일을 더블 클릭합니다. 

4 Procedure Editor에 파일이 열립니다.  

기존 오브젝트에서 소스 불러오기 

1 기존 오브젝트 버튼에서 Load Source를 불러옵니다. 

2 Select Database Object 창이 표시됩니다. 

3 스키마 드롭다운 목록에서 원하는 스키마와 오브젝트 타입을 선택합니다. 

4 오브젝트 타입을 이용하여 필터링 할 수 있고 필터를 포함하거나 

배제하면서 필터링을 시작할 수 있습니다. 

5 오브젝트에 대한 소스를 미리 보려면, 오브젝트 목록에서 오브젝트를 

선택하거나 오브젝트 이름을 더블 클릭하여 Procedure Editor로 직접 

로드합니다. 

6 선택한 오브젝트의 SQL 스크립트가 Select Database Object 창의 SQL 

스크립트 영역에 표시됩니다. 사용자는 자동 미리 보기를 켜고 끌 수 있는 

대화 상자의 맨 위에 위치한 자동 미리 보기 버튼을 토글할 수 있습니다. 

7 OK를 클릭합니다. 

New Procedure 버튼을 사용하여 오브젝트 생성 

1 Create New Procedure 툴 바 버튼을 클릭합니다. 

2 New Procedure Create Options 창이 열립니다. 

3 드롭다운 목록에서 오브젝트 타입을 선택합니다. 

4 Object Name 텍스트 상자를 클릭하고 오브젝트 이름을 입력합니다.  

5 OK를 클릭합니다. 

기본 템플릿에는 함수에 대한 NEWFUNC.SQL, 패키지에 대한 NEWPACK.SQL, 
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프로시저에는 NEWPROC.SQL, 트리거에는 NEWTRIG.SQL가 있습니다. 

View > Options > Proc Templates 페이지에서는 템플릿을 구성할 수 

있습니다. 

TOAD는 템플릿의 키워드에 대한 값을 자동으로 대체합니다. TOAD가 

수행하는 대체는 다음과 같습니다. 

오브젝트 이름:  %YourObjectName% or *YourObjectName* 

Sysdate:   %SYSDATE% 

날짜/시간:   %DATETIME% 

날짜:    %DATE% 

시간:    %TIME% 

사용자 이름:   %USERNAME% (set in TOAD Options, Procedure 

Editor) 

트리거 옵션:   %TriggerOpts% 

예를 들어 다음과 같은 템플릿은 

/* Object Name:  %YourObjectName% */  

/* Date:   %DATE% */ 

다음과 같이 번역됩니다. 

/* Object Name:  My_Proc_Name */ 

/* Date:   2/15/2002 */ 

Procedure Edit 창은 두 개의 패널로 분리됩니다. 왼쪽 패널은 오브젝트나 

패키지 내용 목록인 Package Navigator List를 포함합니다. 모든 패키지는 

목록의 계층 구조에 표시되는 세부 사양(SPEC) 및/또는 Body로 구성됩니다. 

목록의 함수는 f( )로 지정되며 목록의 프로시저는 p( )로 지정됩니다.  

오른쪽 패널은 Procedure Editor로 선택된 오브젝트에 대한 코드를 

포함합니다. 
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다중 탭의 Procedure Editor 패널 

Error 패널은 목록 상자의 왼쪽에 오류를, 오른쪽에 세부 사항을 보여줍니다.  

목록에서 오류를 한번 클릭하여 세부 사항을 표시하면, 편집기 안에서 오류가 

강조 표시됩니다. 오류를 더블 클릭하면 그 Oracle 오류에 대한 Instant 

Messages 화면이 표시됩니다.  

상태 패널에서는 커서의 위치에 대한 열 번호와 행 번호를 보여주고, 코드가 

수정되었는지, 유효한 지, 코드가 성공적으로 컴파일 되었는지, 또는 컴파일 중 

오류가 발생했는지 여부를 보여줍니다.  

패키지 네비게이터 목록과 편집기 사이의 수직 분리자와 오류 패널은 상하로 

크기 조절이 가능합니다. 

View > Options > Procedure Editor tab > Enable Compiling Multiple Objects 

From a Single File 옵션이 선택되어 있을 때만, Procedure Edit 창은 파일마다 

복수의 실행문을 허용합니다.  

Spec은 탭 제목에 (S)로 표시되고, Body는 탭 제목에 (B)로 표시됩니다.  

 

Run button  

Run 버튼은 디버거만 활성화해서 선택된 프로시저를 실행합니다.  

Load Object from Database 버튼을 선택하면 필터 창이 열립니다.  
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네비게이터 목록 버튼(Navigator List Buttons) 

 Refresh Navigator  

 Sort/Do not sort navigator list alphabetically 

 Close navigator list  

 

오른쪽 클릭 메뉴(Right-click menu) 

Procedure Editor에서 작업할 때, 오른쪽 클릭 또는 F10은 오른쪽 클릭 메뉴를 

표시합니다. 

Describe 

Close File/Tab  

New File/Tab 

Comment Block 

Format Statement 

Find Closing Block 

Procedure Editor Desktop 

Read Only 

 

DBMS Output 

View > DBMS Output 메뉴 항목을 선택하면 이 대화 상자가 열립니다.  

DBMS_OUTPUT문 작성 
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tmpVar가 강조 표시되고 Make Output Statement는 오른쪽 클릭 메뉴에서 

선택됩니다. 
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그리고 현재 DBMS_OUTPUT 문의 일부인 tmpvar를 SQL 스크립트에 

붙입니다.  

Blank Output 

사용자는 또한 Blank Output을 선택하여 DBMS_OUTPUT 템플릿을 불러 

자신의 스크립트에 붙이고 공백 섹션을 채울 수 있습니다. 

 

공백 DBMS_OUTPUT 문 작성하기 

1 오른쪽 클릭하여, Blank Output Statement 항목을 선택합니다.  

2 스크립트에서 실행문을 붙이기 원하는 위치를 클릭합니다. 

3 오른쪽 클릭 메뉴나 Edit 메뉴에서 Paste를 선택하면 공백 

DBMS_OUTPUT Statement을 사용자의 스크립트에 붙일 수 있습니다.  
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utPLSQL 

 

TOAD는 Steven Feuerstein의 공개 소스 프로그램인 utPLSQL와 함께 

작동하여 하나의 단위로 PL/SQL 응용 프로그램의 프레임워크를 테스트할 수 

있습니다. UtPLSQL에 대한 더욱 상세한 정보는 

http://oracle.oreilly.com/utplsql에서 확인할 수 있습니다. 공개 소스 프로젝트 

홈페이지를 방문하면 https://sourceforge.net/projects/utplsql/에서 

utPLSQL와 최근 스크립트를 다운 받을 수 있습니다.  

 

Quest Software, Inc는 이러한 지침과 스크립트에 대해 지원해줍니다. 

UtPLSQL에 대한 지원은 앞서 언급한 웹 사이트에서 구할 수 있습니다.  

 

툴 바와 바로 가기에서 utPLSQL 실행 

Chris Rimmer는 다음 단계로 스크립트를 작성하였습니다. 

1 스크립트를 다음 페이지에서 C:\utplsql\runtest(기타 유효한 윈도우 

파일명 가능)로 저장합니다.  

2 Configur/Execute 도구에 대한 메뉴 드롭다운을 클릭하여 Configure를 

선택합니다. Tools Option 창이 열립니다. 

3 Add 버튼을 클릭합니다. Tool Properties 창이 열립니다. 

4 Title 상자에서 제목란에 “Unit Test in utPLSQL”을 입력합니다. 

5 Program 상자에서 SQL*Plus의 경로를 입력합니다.  

6 파라미터 상자에서 다음을 입력합니다. 

$UID/$UPW@$SID @c:\utplsql\runtest $FIL 

런테스트(runtest) 경로는 사용자가 위에서 선택한 것입니다. 

7 바로 가기 상자를 클릭하고 원하는 바로 가기를 입력합니다. 

8 OK를 누르고 종료합니다. 

* 주의: 다음과 같은 공간을 사용하여 디렉터리의 런테스트 스크립트를 설치한 

사용자는 C:\Program Files\Quest\… 파리미터 상자에 작은 따옴표를 

사용해야 합니다. 
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사용자의 소스 코드에는 동일한 규칙이 적용됩니다. 테스트 완료된 패키지나 

유닛 테스트 패키지는 공백을 포함하는 하나의 패스에 있게 되며 $FIL 

파라미터는 작은 따옴표로 막혀 있어야 합니다. 

$UID/$UPW@$SID @'C:\Program Files\Quest 

Software\utPLSQL\runtest.sql' 

'$FIL'  

패키지 파일이나(mypack.pkb와 같은 파일) 유닛 테스트 

패키지(ut_mypack.pks와 같은 파일)를 편집하면, utplsql.test('mypack')가 

실행됩니다. 이는 패키지 이름이 파일명에 반영되는 네이밍 관습을 

사용하느냐에 따라 달라집니다. 

이 스크립트는 TOAD로 작동합니다. 

--RUNTEST.SQL Version 1.0.2 

--This file takes the given filename, strips off its directory and 

--extension and calls utplsql.test with the result. 

--Chris Rimmer 15 Feb 2002 

SET serveroutput ON 

SET verify OFF 

DECLARE 

filename VARCHAR2(100) := '&1'; 

dot PLS_INTEGER; 

slash PLS_INTEGER; 

prefix_len PLS_INTEGER := LENGTH(utconfig.prefix); 

BEGIN 

--Strip off the directory 

slash := INSTR(filename, '\', -1, 1); 

IF slash <> 0 THEN 

filename := SUBSTR(filename, slash + 1); 

END IF; 

--Strip off the extension 

dot := INSTR(filename, '.' , 1, 1); 

IF dot <> 0 THEN 

filename := SUBSTR(filename, 1, dot - 1); 

END IF; 

--Strip off ut prefix 

IF SUBSTR(filename, 1, prefix_len) = utconfig.prefix THEN 

filename := SUBSTR(filename, prefix_len + 1); 

END IF; 

--Now run the test 

utplsql.test(filename); 

END; 

/ 

pause Press ANY KEY TO CLOSE 

EXIT 
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소스 코드 관리(Source Code Management) 

TOAD는 Source Code Control (SCC), Microsoft API를 제공하여 개발 환경과 

소스 콘트롤 제품 사이의 표준 인터페이스를 정의합니다. SCC API는 체크 아웃, 

체크 인, 파일 추가와 같은 일반적인 소스 콘트롤 작동을 수행하는 함수를 

제공합니다.  

다음에 표시된 벤더들은 SCC API를 지원하며 TOAD로 테스트할 수 있습니다: 

§ Microsoft Visual SourceSafe 6.0 

§ PVCS 6.7 (VM 개발 인터페이스가 필요합니다) 

§ StarBase StarTeam 4.2 (Developer Studio Integration 옵션이 

필요합니다) 

§ QVCS 3.5 (Quma) (QVCS 클라이언트를 사용하여 Source Control 

Provider로 QVCS를 추가합니다) 

§ CS-RCS 2.5.140 (구성 요소 소프트웨어) 개인용  

주의: 이러한 소프트웨어 제품의 이전 버전은 TOAD로 테스트되지 않았기 

때문에 호환성에 문제가 있을 수 있습니다. 다른 벤더들은 API에는 알맞지만, 

TOAD로 테스트하지 않았기 때문에 통합 작업을 보장할 수 없습니다.  

각 SCC 컴플라이언트 제품은 레지스트리에 엔트리를 작성하고 SCC 공급 

업체와 SCC 함수를 호출하는 데 사용되는 DLL의 위치를 지정합니다.  

주의: Source Control에서 클라이언트 부분이 반드시 실행되어야 합니다. 

사용자는 Source Control 설치에서 서버 부분만 실행할 수 없습니다. 

작업 폴더(Working Folder) 

TOAD 소스 콘트롤 인터페이스를 사용하기 위해서는 설정해 놓은 작업 폴더가 

있어야 합니다. 예를 들어, 사용자가 Microsoft Visual SourceSafe를 사용하고 

있다면 Microsoft Visual SourceSafe를 열게 될, 작업 폴더를 설정합니다. 

폴더를 오른쪽 클릭하고 Set Working Folder 옵션을 선택합니다.
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Source Control 옵션 

사용자는 View > Options > Source Control 페이지에서 Source Control 

옵션을 선택하여 구성한 SCC에 대한 인터페이스를 설정해 놓아야 합니다. 

Source Control 옵션 설정하기 

1 드롭다운에서 TOAD와 함께 사용할 Source Control Provider를 

선택합니다. Source Control Provider 드롭다운 목록에는 레지스트리에서 

찾을 수 있는 SCC 공급 업체가 표시됩니다. 공급 업체를 바꾸려면, 

TOAD를 다시 시작해야 합니다. 

2 Prompt for Comment 체크박스에서는 액션과 주석을 저장할 수 있는 

대화 상자의 표시 여부를 결정합니다.  

Source Control은 Procedure Editor에서 실행됩니다. Procedure Editor의 툴 

바는 체크 인과 체크 아웃 버튼을 포함합니다. 

 Check file out of source control 

 Check file into source control 

다른 모든 기능은 오른쪽 클릭 메뉴에서 확인할 수 있습니다. 오른쪽 클릭 

메뉴에는 다음과 같은 하위 메뉴 항목을 갖는 Source Control 메뉴 항목이 

포함됩니다. 

Check-out File 

파일이 체크 아웃될 때, 그 파일을 디스크로 다시 로드합니다.(로드된 파일과 

다를 수 있습니다) 이 파일은 쓰기가 가능합니다.   

Check-in File 

파일이 체크 인 되면, 다시 읽기만 가능하도록 설정됩니다.  
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Undo-checkout 

이 명령은 변경 작업을 무시하고 읽기만 가능한, 원래 버전으로 전환합니다. 

예를 들어 사용자가 데이터베이스에 저장된 변경 작업을 원하지 않을 경우, 이 

명령이 유용합니다. 

Get latest version  

소스 콘트롤에서 파일을 새로 고침하고 파일을 다시 로드합니다.(여전히 읽기만 

가능합니다) 

Add File 

현재 파일을 소스 콘트롤에 추가하고 읽기만 가능하도록 다시 로드합니다. 

Select project 

사용할 소스 콘트롤 프로젝트를 선택할 수 있는 대화 상자를(공급 업체마다 

다름) 생성합니다. 선택된 프로젝트는 TOAD 세션에서 .ini 파일로 저장됩니다.  

체크 아웃되지 않은 파일은 읽기만 가능한 상태입니다. 읽기만 가능한 파일은 

편집할 수 없습니다. 모든 SCC 함수는 현재 로드된 파일을 기반으로 

동작합니다. Source Control 기능은 데이터베이스 오브젝트에서는 동작하지 

않고 파일에서만 동작합니다. 

TOAD에서 처음으로 Source Control을 사용하는 방법 

1 클라이언트를  설치합니다. 

2 사용자의 클라이언트가 SCC API를 지원하도록 구성되었는지 확인합니다. 

클라이언트나 클라이언트 설치에서 레지스트리 키가 작성되었는지 

확인하면 됩니다. 

3 View > Options > Source Control로 이동합니다. 

4 SCC 공급 업체를 선택하고 원하는 항목을 선택, 또는 해제합니다.  
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5 작업하려는 파일을 Procedure Editor로 불러옵니다. 소스 콘트롤 (Source 

Control)이 Procedure Editor에서 실행 중인지 확인하시기 바랍니다. 

6 Procedure Editor를 오른쪽 클릭하여 Source Control > Select Project를 

선택합니다. 

7 프로젝트를 선택하는 대화 상자에 SCC 공급 업체가 표시됩니다. 공급 

업체와 구성에 따라, 데이터베이스에 로그인 하거나, 검색할 것을 

요구하기도 합니다. 여기에서, 작업 폴더를 설정할 수도 있습니다. 이에 

대한 세부 사항은 공급 업체의 문서를 참조하십시오. 

주의: 선택된 프로젝트에 대한 작업 디렉터리는 사용자가 파일을 로드한 

디렉터리와 일치해야 합니다. 

8 파일이 Source Control에 이미 저장되어 있다면, 사용자는 이를 체크 인, 

또는 체크 아웃 할 수 있습니다. 오른쪽 클릭하여 Source Control > Add 

File을 선택하고, 파일을 소스 콘트롤에 추가할 수도 있습니다. 그러면 

파일이 체크 인 상태가 되므로, 이를 변경하려면 파일을 체크 아웃 

해주어야 합니다.  

 

 

스키마 브라우저(Schema Browser) 

Schema Browser 창을 불러오는 방법 

§ TOAD의 기본 툴 바에서 버튼을 클릭합니다.  

§ 메뉴 항목의 Database > Schema Browser를 선택합니다. 

§ View > Options > StartUp 대화 상자에서 새로운 연결이 작성되면 

Schema Browser가 자동으로 열리게 설정합니다.  

 

 



 

 

스키마 브라우저 사용 

오브젝트 탭(Object Tabs) 

오브젝트 패널의(창의 왼쪽) 탭 영역에서 오른쪽 클릭 메뉴는 사용자가 개인 

탭을 표시하거나 숨길 수 있는 메뉴를 보여줍니다. 

Configure Browser Tabs 창 

탭 영역에서 오른쪽 클릭 메뉴는 Configure 메뉴 항목을 포함하는 데, 이 

항목의 Configure Browser Tabs 창에서는 탭의 이름과 배열을 새로 지정할 수 

있습니다. 창에서 Up Arrow 또는 Down Arrow를 클릭하여 목록에서 전체 행을 

상하로 움직일 수 있습니다.  

오른쪽 클릭 메뉴 패널(Panels Right-Click Menus) 

Schema Browser 패널에는 오른쪽 클릭 메뉴가 포함됩니다. 

네비게이션(Navigation) 

Schema Browser를 처음 열었을 경우, 선택한 스키마 디스플레이에서 Tables 

탭과  모든 테이블의 목록을 기본값으로 선택합니다.  

Change Active Session 버튼의 옆에는 드롭다운 버튼이 있습니다. 이 드롭다운 

목록은 액티브 세션을(active session) 모두 표시합니다. 목록에서 세션을 

클릭하여 액티브 세션을 변경할 수 있습니다.  

 Refresh All 

Refresh All 버튼은 Schema Browser에서 모든 사항을 새로 고침 해줍니다.  

 Refresh Detail  

Refresh Detail 버튼은 세부 사항 패널만을 새로 고침 해주고 재쿼리합니다.  

 Clear Data Grid Filters 

모든 데이터 그리드 필터를 삭제합니다. 
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필터 

다음 오브젝트는 오브젝트 이름과 기타의 필터링 기능을 갖고 있습니다. 
테이블(Tables), 프로시저(Procs), 트리거(Triggers), 뷰(Views), 
동의어(Synonyms), 제약 조건(Constraints). 필터 툴 바 버튼을 클릭하고 
“A로 시작”같은, 필터 조건을 입력합니다.  

스키마 브라우저 옵션 

View > Options (또는 Configure Options 버튼) > Schema Browser을 

선택하여 Schema Browser Options 메뉴에 액세스합니다. 옵션은 2페이지에 

표시되며, Page 1과 Page 2 탭을 통해 액세스합니다.  

테이블(Tables) 

이번 장에서는 Table 탭에 관해 상세히 다루고, 몇 가지 다른 탭을 요약합니다. 

Schema Browser에서 대부분의 탭과 함수는 유사한 방식으로 작동합니다. 

Tables 페이지의 오른쪽 클릭 메뉴에는 이 메뉴를 통해서만 액세스할 수 있는 

Incrementally Drop Table 메뉴 항목이 포함됩니다. 

Incrementally drop table 

서버 성능에 영향을 주지 않고 선택한 날에만 단계별로 큰 테이블을 드롭하게 
해주는 항목입니다  

오브젝트 패널 

 Create Script 

Create Script 버튼은 기본값으로 선택된 Options 탭이 있는 Table Script 

Creation 창을 표시합니다. 

Options 탭, Output 탭 

 

 Create Table 

Create Table 버튼은 Create Table 창을 불러옵니다. Create > Table 메뉴 

항목을 선택하여 액세스할 수도 있습니다. 
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 Alter Table 

Alter Table 버튼은 Tables 창을 불러옵니다. 이 창에서는 열을 드롭하고 수정, 

추가할 수 있습니다.  

 Export Data 

Export Data 함수 기능에서는 선택된 테이블에서 데이터에 대한 “INSERT 

INTO” SQL 문을 작성합니다. Export Data 버튼은 Table 페이지의 왼쪽 

패널에서 선택한 테이블에 대해 Data Export window를 표시합니다.  

 
여기서는 사용자 프로필 오브젝트를 선택하고 Export Data 버튼을 

클릭하였습니다. 이는 결과 Data Export 창에 있습니다.  

 Load table in SQL Modeler  

선택된 테이블을 SQL Modeler로 로드해 줍니다. 이 함수는 Table Objects 

Panel의 오른쪽 클릭 메뉴에서 Model Table 메뉴 항목을 선택하여 액세스할 

수 있습니다. 

 Analyze Table 

Analyze Table 버튼을 클릭하여 Analyze Tables 창을 표시합니다. 
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옵티마이저는 더 나은 쿼리를 실행할 수 있습니다. 

 

 Table Filter  

Table Filter 버튼은 테이블에 대한 Browser Filters 창을 표시합니다.  

Browser Filters 버튼은 테이블, 프로시저, 트리거, 뷰, 동의어, 제약 조건에 

대한 탭에서 선택할 수 있습니다. 모든 Browser Filter 창은 유사한 

인터페이스를 갖습니다. 

 

여기서 SCOTT 스키마의 테이블은 EMP로 시작되는  

이름의 테이블을 제외하고 모두 필터링됩니다. 

드롭다운 필터 목록에는 다음과 같은 선택 항목이 들어 있습니다. 

§ Starts with  

§ Includes 

§ Ends with 

§ Not like 

필터는 SCHEMA가 스키마 이름인, TOAD\TEMPS 폴더 안에 

SCHEMA.FLT라는 파일 이름으로 저장됩니다. 이 파일을 편집해서는 안됩니다!  
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 Rebuild Table 

 Compile Dependencies 

사용자의 테이블이 Procedure 또는 View에 의해 호출되면, 이 버튼은 

종속성를 컴파일합니다.  

 Drop Table 

 Truncate Table 

 

세부 사항 패널 

세부 사항 패널 테이블에는 선택된 테이블에 대한 다양한 세부 사항을 

표시하는 탭이 포함됩니다. 

Table - Columns 

Table - Columns Details Panel 버튼 

Add a Column  

Table - Indexes 

Table - Constraints 

Table - Triggers 

Table - Data 

Table - Scripts 

Table - Grants 

Table - Partitions 

Table - Stats/Size 

Table - Referential 

Referential 탭은 테이블의 계층 구조를 표시하고, 선택된 테이블이 다른 

테이블과 참조 테이블이 선택된 테이블을 어떻게 참조하는지 보여 줍니다.   
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Table -Used by 

Used By 탭은 뷰, 트리거, 함수, 프로시저, 패키지와 같이 선택된 테이블을 

참조하는 오브젝트를 보여줍니다.  

 

뷰(Views) 

오브젝트 패널은 기본 작성, 편집, 저장, 컴파일, 필터와 드롭 버튼 뿐만 아니라, 

뷰 스크립트 구문을 작성하고, SQL Editor에서 선택된 뷰의 SQL 스크립트를 

열어주며. 선택된 뷰의 권한 창을 표시하고 공개 동의어를 작성하며 종속성을 

컴파일해 주는 버튼을 포함합니다. 

세부 사항 패널은 Columns, Source, Data, Grants, Deps(uses)와 Deps(Used 

by) 탭을 포함합니다. Dependencies 탭은 종속성을 표시합니다. 종속성 계층 

구조에서는 종속 트리가 표시될 것입니다. Deps 오른쪽 클릭 메뉴에서는 

선택된 오브젝트의 개요를 컴파일 하고 기술하며 복사할 수 있습니다. Deps 

목록에서 오브젝트를 선택하여 팝업 기술 창이 열리면, <F4>를 누릅니다. 

동의어(Synonyms) 

테이블, 프로시저, 패키지, 함수, 시퀀스, 뷰, 동의어와 같은 오브젝트에 대해 

동의어를 작성할 수 있습니다. 이 중에 동의어는 원래 오브젝트를(original 

object) 지칭합니다.  

기본적인 작성 버튼과 드롭 버튼 외에도, 패널은 여러 타입의 동의어를 필터링 

할 수 있는 Filters 버튼을 포함합니다. SYS/SYSTEM 스키마가 여러 동의어를 

포함하고 더욱 쉬운 네비게이션을 위해 이를 필터링하려는 사용자들이 많기 

때문입니다. Show Public synonyms except those for objects owned by 

SYS/SYSTEM은 이러한 이유에서 기본값으로 설정됩니다. 

세부 사항 패널은 동의어가 지정하는 오브젝트의 세부 사항을 표시합니다. 이 

패널에서 테이블, 뷰, 저장 프로시저를 지칭하는 동의어에 대한 세부 사항을 

확인할 수 있습니다. Unknown Objects는 UNKNOWN으로 표시됩니다.  

세부 사항 패널에서는 오브젝트와 관련된 탭과 세부 사항도 표시해줍니다. 예를 

들어, 뷰가 오브젝트라면 세부 사항 패널은 Object View 탭이 세부 사항 

패널에 표시하는 같은 탭을 포함하며, 동일한 관련 세부 사항을 표시합니다.  
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프로시저(Procedures) 

 

PL/SQL Procedures, Functions, Packages 목록에서 분홍색의 X는 유효하지 

않은(빨간색 X) 함수나 프로시저를 하나 이상 포함하는 Package에 대한 

것입니다.  

 

기본적인 저장과 드롭 버튼 뿐만 아니라, 패널은 다음과 같은 버튼을 

포함합니다. 

Proc Edit 버튼은 프로시저를 선택하면 활성화됩니다. 오브젝트 패널에서 

선택한 프로시저에 대해 Procedure Edit 창을 열어 줍니다. 드롭다운에서 Load, 

Load Spec Only, 또는 Load Body Only를 선택할 수 있습니다. 

Compile 버튼은 선택한 프로시저, 함수, 패키지를 컴파일 해줍니다. 

드롭다운에서 Compile, Compile Spec Only, or Compile Body Only를 선택할 

수 있습니다. 

Compile All 버튼은 모든 프로시저와 함수, 패키지, 트리거를 현재 스키마에서 

컴파일할 수 있습니다. 8.1.7 버전 보다 이전의 데이터베이스에서는 유효하지 

않은(INVALID) 오브젝트만을 컴파일합니다.  

Procs Filter 버튼은 프로시저에 대한 Browser Filter 대화 상자를 열어 줍니다.  

필터에 대한 자세한 사항은 217페이지의 Filters를 참조하십시오.  

 

Compile Dependencies 버튼은 선택된 프로시저의 종속성을 컴파일합니다. 

예를 들어, 프로시저 A가 프로시저 B를 호출할 때, 프로시저 B를 선택하고 

Compile Dependencies 버튼을 클릭하면 TOAD는 프로시저 A를 다시 

컴파일해 줍니다. 선택된 프로시저의 종속성을 컴파일 할 지 묻는 대화 상자가 
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표시됩니다. Yes나 No를 선택합니다. 

Execute Procedure 버튼은 Set Parameters 창을 열어 주므로, 인자를 

입력하고 OK를 클릭하면 프로시저를 실행할 수 있습니다.  

Privileges 버튼을 사용하면 다른 사용자의 스키마 계정이나 롤에 대해 선택된 

프로시저의 권한을 확인하고 수정할 수 있습니다.  

Public Synonym 버튼에서는 선택된 프로시저, 함수, 패키지에 대한 공개 

동의어를 작성할 수 있습니다. 

세부 사항 패널에는 Code, Arguments, Deps (Uses), Deps (Used by), Errors, 

Grants에 관한 탭이 포함됩니다. 

Dependencies 탭은(Uses와 Used By) 패널의 상단에 종속성을 표시해줍니다. 

종속성의 계층 구조가 있다면, 종속성 트리가 표시됩니다. Deps 오른쪽 클릭 

메뉴에서는 선택된 오브젝트의 개요를 컴파일하고 기술하며, 복사할 수 

있습니다. 

Deps 목록에서는 항목을 선택하고 <F4>를 눌러서 오브젝트를 상세히 기술하는 

팝업 창을 열 수 있습니다.  

Errors 탭은 선택된 프로시저를 컴파일 할 때, 발생했던 최종적인 오류를 

표시합니다. 오류를 클릭하면 세부 사항 패널의 하단에 표시되는 스크립트에서 

오류의 위치가 강조 표시됩니다. 

 

트리거(Triggers) 

Triggers 목록에서 항목의 왼쪽에 위치한 여러 아이콘은 다음과 같이 

표시됩니다.  

§ Red Circle with a slash 

트리거가 비활성화 되었음을 의미합니다. 

§ Red X 

트리거가 유효하지 않으며 재컴파일이 필요함을 의미합니다.  

§ White page 

트리거가 유효하며 활성화되었음을 의미합니다. 
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Objects 패널은 저장, 컴파일, 필터, 드롭 버튼을 포함합니다. 편집이 가능한 

Procedure Editor에서 선택된 트리거를 지정하는 Proc Edit 버튼(Trigger to 

Proc Editor)을 포함합니다.   

세부 사항 패널은 선택된 트리거에 대한 정보를 표시합니다. Columns 탭은 열, 

테이블, 테이블 소유자와 용도를 표시해 줍니다. Source 탭은 선택된 트리거에 

대한 SQL 스크립트를 표시합니다. 

<CTRL> A를 눌러서 트리거를 선택할 수 있으며, <CTRL>C를 누르면 

클립보드에 이를 저장할 수 있습니다. 

 

인덱스(Indexes) 

인덱스 목록에서 "101" 아이콘은 BITMAP 인덱스를 지칭하며, Yellow Square 

+ Red Triangle + Blue Circle 아이콘은 UNIQUE 인덱스를(non unique와 

상반됨),“f ( )”는 함수 기반 인덱스를 지칭합니다.  

 

기본적인 작성, 수정, 드롭 버튼 뿐만 아니라, 패널에는 다음과 같은 버튼이 

포함됩니다. 

Create Script 버튼은 선택된 인덱스의 Create Index 스크립트를 클립보드에 

복사합니다. 

Rebuild Index 버튼은 테이블 인덱스를 재구성할 수 있습니다. 인덱스는 쿼리 

성능을 향상시키기 위해 정기적으로 재구성해야 합니다.  

Rebuild Index 창과 Rebuild Multiple Indexes(Tools 메뉴 또는 Schema 

Browser > Tables right-click menu에서 액세스할 수 있음)에 대한 자세한 

정보는 TOAD 도움말을 참조합니다.   

Analyze Index 버튼에서는 선택된 인덱스에 대한 통계를 수집하여 COST 기반 
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쿼리 최적화를 수행하므로 옵티마이저는 더 나은 쿼리를 실행할 수 있습니다. 

Filters Indexes List 버튼은 Index Names와 Table Names를 필터링 할 수 

있는 Browser Filters 창을 열어 줍니다. 

세부 사항 패널 탭에는 Column , Stats, Partitions,  Script가 포함됩니다. 

 

제약 조건(Constraints) 

Constraints 탭은 오브젝트 패널에서 제약 조건을 표시합니다.  

제약 조건은 활성화 또는 비활성화 할 수 있습니다. 제약 조건을 비활성화 할 

경우(현재의 조건이나 모든 조건을 비활성화), 비활성화 되도록 선택한 제약 

조건 중 일부가 종속성을 갖는다면, 종속성을 갖는 제약 조건은 비활성화 할 수 

없다는 Oracle 오류 메시지가 표시됩니다. 오브젝트 목록에서 빨간색 X가 

비활성화 한, 제약 조건 옆에 표시됩니다. 

Constraints Filter 버튼은 제약 조건에 대한 Browser Filter 대화 상자를 열어 

줍니다. 

세부 사항 패널은 타입, 상태, 테이블과 소유자를 포함하여 선택된 제약 조건에 

대한 정보를 제공합니다. 

시퀀스(Sequences) 

Sequences는 Oracle이 유지 관리하는 기본 카운터입니다.  

오브젝트 패널은 기본적인 작성, 변경, 드롭 버튼 뿐만 아니라, 선택된 시퀀스에 

대한 권한 창을 열어주는 버튼과 선택된 시퀀스에 대한 공개 동의어를 

작성하는 버튼을 포함합니다.  

세부 사항 패널에서 Grants 탭의 버튼에서는 선택된 시퀀스나 모든 시퀀스에 

대한 권한을 취소 합니다.  

JAVA 

TOAD는 Oracle 8i과 더 높은 버전의 데이터베이스에 대한 JAVA 탭을 

포함합니다. 여기서는 Java 오브젝트의 목록을 보여줍니다. 오른쪽 클릭 

메뉴에는 Publish Java to PL/SQL 메뉴 항목이 포함됩니다. 세부 사항 패널에는 

Code 탭이 있습니다. 
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DB 링크(DB Links) 

DB Links는 사용자가 속해 있는 데이터베이스에서 가능한 링크를 목록으로 

보여줍니다. Link는 공개이거나(모든 스키마가 사용) 개인적일 수 

있습니다(링크를 작성한 스키마만 사용 가능). 

 

목록에서 공개 연결 옆에는 해당 심볼( )이 있습니다. 

DB Links는 각 테이블이나 뷰 이름의 마지막 쿼리에서 사용됩니다.  

패널은 기본적인 드롭 버튼 뿐만 아니라, Creat Public DB 링크 스크립트를 

클립보드로 복사하는 Copy script to clipboard 버튼과 Creat Database Link 

창을 열어주는 Create new database link 버튼을 포함합니다. 

세부 사항 패널은 오브젝트 목록에서 소유자, 호스트, 사용자 이름과 선택된 DB 

링크에 대해 링크가 작성된 시간과 날짜를 표시합니다. 

사용자(Users) 

사용자를 작성, 수정, 드롭 할 수 있고 SQL 스크립트를 클립보드에 작성하고 

복사할 수 있습니다. 뿐만 아니라, 롤과 권한에 대한 세부 사항을 확인할 수 

있고 사용자를 복사할 수도 있습니다.(이름을 변경할 수 있음) 계정을 잠그거나 

잠금 해제할 수 있습니다. 잠긴 계정은 오브젝트 목록에서 이름의 왼쪽에 잠금 

아이콘으로 표시됩니다. 오브젝트 목록 오른쪽 클릭 메뉴에는 Expire User 

기능이 포함됩니다.  

세부 사항 패널은 Info, Roles, Privileges에 관한 탭을 포함하고 있습니다.  

Roles과 Privileges 탭에는 Revoke와 Revoke all 버튼이 있기 때문에 선택된 

롤이나 권한을(Revoke) 취소하거나 모든 롤이나 권한을(Revoke all) 취소할 수 

있습니다.  

 

작업(Jobs) 

작업은 작성, 변경, 실행이 가능하며, 온라인이나 오프라인으로 배치하여 작업 

세부 사항을 확인할 수 있습니다.  

세부 사항 패널은 LOG USER, NEXT DATE, INTERVALS와 같은, 선택된 
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작업에 대한 다양한 파라미터를 보여줍니다. 선택된 작업의 소스는 세부 사항 

패널의 하단 페인에 표시됩니다.  

타입(Types) 

이 페이지에서는 사용자 정의 데이터 타입을 작성, 검색, 편집할 수 있습니다.  

이 기능은 Oracle 8이나 더 높은 버전의 데이터베이스에만 사용할 수 있습니다.  

View > Options > Types Tab 페이지에서 이 옵션을 설정할 수 있습니다.  

오브젝트 패널은 사용자 정의 데이터 타입을 계층 구조적으로 표시합니다.  

Edit User Type 버튼은 사용자가 선택한 항목에 따라 Edit Object Type 창이나 

Edit Collection Type 창을 열어 줍니다. 

큐 테이블(Queue Tables) 

이 페이지에서는 사용자가 Oracle의 내장 DBMS_AQADM 패키지를 사용하여 

큐 테이블을 작성, 변경, 드롭 할 수 있습니다.  

이 기능은 Oracle 8과 더 높은 버전의 데이터베이스에서만 사용할 수 있습니다. 

Oracle 8.0에서는 큐 테이블 변경을 지원하지 않습니다. 

큐(Queues) 

이 페이지에서는 큐를 작성, 변경, 드롭 할 수 있으며, Oracle 내장 패키지인 

DBMS_AQADM를 사용하여 큐에 대한 인큐 또는 디큐를 활성화하거나 

비활성화 할 수 있습니다.  

이 기능은 Oracle 8과 더 높은 버전의 데이터베이스에서만 사용할 수 있습니다. 

 

즐겨찾기(Favorites) 

Favorites 탭은 구성 가능한 탭으로, Schema Browser 탭과는 다른 오브젝트를 

하나의 탭에 추가할 수 있습니다. 오브젝트는 하나 이상의 폴더에 그룹화할 수 

있습니다. 여러 폴더는 하나의 인스턴스에 명시적입니다. Details Panel은 

오브젝트 타입에 대한 적절한 세부 사항과 툴 바, 탭, 오른쪽 클릭 
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메뉴(오브젝트에 대한 작업수행 하는 메뉴 항목을 포함)를 표시합니다. Schema 

Browser 탭에서 여러 탭이 오른쪽 클릭에서 Add to Favorites 목록 메뉴 

항목을 포함합니다. 

 

Schema Browser Tasks 

이 절에서는 Schema Browser로 수행하는 여러 작업을 단계별로 소개합니다.  

클립보드에 테이블 복사와 열 이름 표시 

다중 선택 목록과 <CTRL>C를 통해 Table/Columns 탭이나 Views/Columns 

탭의 목록에서 열 이름을 복사할 수 있습니다.  

Tables > Columns 

1 복사하려는 열을 클릭합니다. 두 개 이상의 열을 선택하려면 

<CTRL>을 누르고 선택하려는 열을 클릭합니다. 열의 연속적인 블록을 

선택하기 위해, 시작점을 선택하고 <SHIFT>를 누른 후, 블록화된 

섹션의 종결점을 클릭합니다. 

 

2 <CTRL>C를 누르거나 메뉴에서 Edit > Copy를 선택합니다. 

선택 사항이 클립보드에 복사됩니다.  

예를 들어, CUSTOMER_ID, CITY, ZIP_CODE를 선택했다면, 이는 

클립보드에 복사됩니다.  

 

테이블 데이터 특정 순서로 내보내는 방법 
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Schema Browser window > Tables page > Export Data 버튼에서 액세스한 

Data Export window 창에서는 테이블 데이터를 파일이나 클립보드 중 하나에 

내보낼 수 있습니다. 특정 레코드에만 필터링하고 싶다면, Options 탭에서 

WHERE 절을 where 텍스트 상자에 입력합니다.  

데이터를 정렬하려면, “WHERE”절 뒤에“ORDER BY”절을 추가합니다. 

TOAD는 전체 문자열을 SQL의 끝에 추가하고 이를 실행합니다. 

 

 

스키마 드롭다운 목록에서 오브젝트를 포함하지 않는 스키마의 필터링 

몇 가지의 스키마만 테이블, 뷰와 같은 오브젝트를 소유하는 데이터베이스를 

갖고 있다면, 다른 모든 스키마는 엔드 유저 로그인으로 사용됩니다. View > 

Options > Schema Browser > Page 1 탭으로 이동해서 Only show users that 

own objects in dropdown lists을 선택합니다. 

 

Quest ScriptRunner 

Quest ScriptRunner는 TOAD 디렉터리 안에 포함된, 하위 지 관리 스크립트 

실행 유틸리티로 DDL과 DML 스크립트를 실행할 수 있습니다.  
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SQL Modeler 

SQL Mod eler는 Select, Insert, Update, Delete 문의 프레임워크를 빠르게 
작성할 수 있습니다. 테이블, 뷰, 동의어와 조인 열, 선택 열을 선택할 수 있으며 
원하는 실행문 타입을 작성할 수 있습니다.  

 

Kill/Trace Session 

TOAD Reports 

TOAD Reports에서는 미리 서식이 지정된 다양한 보고서를 출력할 수 

있습니다. View > Reports 메뉴 항목을 통해 이 창에 액세스할 수 있습니다. 

또는 툴 바의 Reports 버튼을 클릭해도 됩니다. 

보고서를 실행하려면 

1 보고서를 선택합니다. 

2 파라미터를 입력합니다. 

3 Run 버튼을 클릭합니다. Print Preview 버튼이 표시됩니다. Print Preview 

창에 미리 서식이 지정된 보고서가 표시됩니다. 여기서 프린터 옵션을 

설정할 수 있습니다. 

HTML Schema Doc Generator 

이 창은 Tools > HTML Schema Doc Generator 메뉴 항목을 통해 액세스할 

수 있습니다. 

이 창에서는 Source 탭에서 하나 이상의 스키마를 선택하고 화면 상단의 

Begin HTML Schema Doc Generation 버튼을 통해 스키마를 설명하는 HTML 

문서를 작성할 수 있습니다. HTML 문서를 통한 하이퍼링크를 사용하여 문서의 

각 섹션으로 이동할 수 있습니다. 

 

네트워크 유틸리티 

File > Network Utilities 메뉴 항목을 통해 네트워크 유틸리티 창에 액세스할 

수 있습니다. 
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View > Options > Network Utilities 페이지를 통해 Network Utilities 옵션에 

액세스할 수 있습니다. 

Telnet 

Telnet(Telecommunications Network)은 다른 컴퓨터에 연결하여 명령을 내릴 

수 있는 세션을 여는 프로토콜입니다. 이 프로토콜은 Internet RFC 854에 

정의되어 있습니다. 

드롭다운 상자에 Host Name/IP(호스트 이름 또는 IP 주소)를 입력합니다. 

Port에 포트 번호를 입력합니다. 

Connect 버튼을 클릭합니다. 

로그인 이름을 입력하고 <Enter> 키를 누른 다음 암호를 입력하고 <Enter> 

키를 누릅니다. 

RExec 

RExec 탭에서는 Unix 명령을 실행할 수 있습니다. 이 기능이 작동하려면 

서버가 Rexecd 를 실행하고 있어야 합니다.  

Ping 

ICMP를 사용하여 네트워크의 다른 시스템에 연결할 수 있으며 연결의 성공 

여부를 알 수 있습니다. 

TNS Ping 

TNS Ping은 TNS Listener 가 tnsnames.ora 파일의 연결 문자열 중 하나에 

대해 실행 중인지 여부를 결정하는 Oracle 유틸리티입니다 

IP Addresses 

IP Addresses 탭에서는 호스트 이름이나 URL을 입력하여 IP 주소를 

알아내거나, IP 주소를 입력하여 호스트 이름이나 URL을 알아낼 수 있습니다. 

 

Object Search 

 Object Search 버튼을 메인 툴 바에 있습니다. 

툴 바 버튼을 클릭하거나 Tools > Object Search 메뉴 항목을 선택하여 Object 

Search 창을 열 수 있습니다. 
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Object Search 창 사용 방법 

1 드롭다운에서 Schema/Owner를 선택합니다. 

2 Exclude Sys and System 체크박스를 적절하게 선택하거나 선택 

해제합니다. 

3 Search for 상자에 검색어를 입력합니다. 

4 적절한 Object Search 체크박스를 선택하고 드롭다운 상자에서 필터 

유형을 선택합니다. Text occurs anywhere, Starts with 또는 Exact 

match를 선택할 수 있습니다. 

5 적절한 Source Search  체크박스를 선택합니다. 검색을 좀더 세부적으로 

필터링하려면 대소문자를 지정할 수 있습니다. 

6 Search 버튼을 클릭하여 검색을 시작합니다. 

7 결과가 결과 그리드에 표시됩니다. 일치하는 것이 없으면 비어 있는 검색 

결과가 표시됩니다. 

8 결과 그리드에서는 TABLE, VIEW 또는 PROCEDURE를 더블 클릭할 수 

있습니다. 그러면 오브젝트에 대한 세부 창이 나타납니다. 

Master/Detail 레코드 브라우저 

Master/Detail 레코드 브라우저는 포린 키 제약 조건을 기반으로 합니다. 

Master/Detail 레코드 브라우저 사용 방법 

1 Tools > Master Detail Browser를 선택합니다. 

2 드롭다운 목록에서 Schema를 선택합니다. 

3 드롭다운 목록에서 Table을 선택합니다. 

4 Related tables 드롭다운에서 테이블을 선택합니다. 

5 이제 기본 테이블에서 항목을 선택하면 관련 테이블이 연관된 세부 

항목으로 채워집니다. 
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여기에서는 DEPT 테이블을 SCOTT 스키마에서 선택했습니다. 그런 다음 Related Tables 

드롭다운에서 EMP 테이블을 선택했습니다. 메인 테이블에서 NEW YORK를 선택했고, 

EMP 그리드에는 뉴욕 직원만 표시됩니다.  

 

테이블 재빌드 

테이블을 재빌드하고 열을 드롭하거나, 열 이름을 바꿀 수 있습니다. 테이블이 

차지하고 있는 공간을 통합할 수도 있습니다. 이 창은 Tools > Rebuild Table 

메뉴 항목을 통해 열 수 있습니다. 이 창은 테이블을 재빌드할 완전한 

스크립트를 생성합니다. 필요한 경우 이 스크립트를 편집하여 사용자 정의할 수 

있습니다. 

테이블을 재빌드 하려면 

1 Rebuild Table 창에서는 소유자를 변경할 수 없으므로 테이블 소유자로 

로그온합니다.  

2 Tools > Rebuild Table 메뉴 항목을 클릭합니다. 

3 Tables 드롭다운 목록에서 재빌드할 테이블을 선택합니다. 

4 Options 탭에서 옵션을 선택합니다. 

5 Storage 탭에서 저장 파라미터를 선택합니다. 원래의 저장 파라미터를 

사용하거나 현재 테이블 크기를 초기 확장으로 사용할 수 있습니다. 그러면 

모든 범위들이 하나의 범위로 결합되어 디스크 성능이 더 빨라집니다. 

6 Columns 탭에서 위쪽 목록의 열을 더블 클릭하여 테이블에서 
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제외(드롭)시킵니다. 열 이름을 변경하려면 해당 열을 선택한 다음(위쪽 

목록에서) 잠시 후 다시 한 번 클릭합니다. 그런 다음 새 이름을 

입력합니다. 

7 SQL 탭을 클릭합니다. 테이블 재빌드 스크립트가 구성되어 표시됩니다. 

이제 스크립트를 파일로 저장하거나 클립보드에 복사할 수 있습니다. 

스크립트를 실행하려면 복사하여 SQL Edit 창에 붙여넣고 실행합니다. 

다른 스키마가 소유한 인덱스는 테이블 재빌드 과정에서 다시 빌드되지 

않습니다. 

SGA Trace Optimization 

Tools > SGA Trace Optimization 메뉴 항목을 통해 이 창에 액세스할 수 

있습니다. 이것은 DBA(데이터베이스 관리자) 기능입니다. 

Oracle의 SGA(System Global Area Oracle Shared Memory)는 최근 사용한 

SQL 문의 풀입니다. 이 풀은 크기가 제한되어 있기 때문에 모든 SQL 문이 

SGA에 영구적으로 유지되는 것은 아닙니다. 사용 빈도가 적은 실행문이 새 

실행문으로 교체됩니다.  

이렇게 필터를 설정한 다음에는 Refresh the List of Statements 툴 바 버튼을 

클릭하십시오. 

특정 SQL 문을 좀더 자세히 다루려면 Load selected statement into the SQL 

Editor 툴 바 버튼을 클릭하십시오. 

툴 바 버튼을 사용하면 SGA를 비울 수 있습니다.(Flush the SGA) SGA는 

Oracle이 최근 실행한 실행문을 캐시하는 공유된 SQL 풀이라는 점을 

주의하십시오. 이 풀을 비우면 재처리 속도가 빨라집니다. Flush the SGA 

버튼을 풀의 모든 내용을 제거합니다. 

아래쪽 창의 SQL 텍스트 및 탭(SQL, Execution Stats 및 Explain Plan)은 

선택한 SQL에 대한 세부 사항입니다. 

Execution Stats 

선택한 SQL 문에 대한 정보가 표시됩니다. 

SQL 

선택한 SQL 문의 전체 SQL이 표시됩니다. 
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SQL 탭을 클릭했을 때 "SQL Body Unavailable" 메시지가 나타나면 SQL이 

최근 사용한 SQL 문의 풀인 Oracle의 SGA에 없는 상태입니다. 이 풀은 크기가 

제한되어 있기 때문에 모든 SQL 문이 SGA에 영구적으로 유지되는 것은 

아닙니다. 사용 빈도가 적은 실행문이 새 실행문으로 교체됩니다. 

Explain Plan  

SQL 공유 풀에 선택된 SQL 문의 Explain Plan을 표시합니다. 실행문에서 

참조된 오브제트에 액세스할 수 있는 권한이 있는 경우에만 실행문의 실행 

계획을 볼 수 있습니다. 

Java 기능 

TOAD에는 다음의 Java 기능이 포함되어 있습니다. 

Java Manager를 통한 Java 클래스의 로드/드롭 

Java to PL/SQL 마법사를 통해 Java 클래스를 PL/SQL 패키지로 게시 

Schema Browser에서 Java 소스/클래스/리소스를 탐색 

SQL Editor에서 Java 소스 작성 

 

옵션 TOAD-DBA 모듈 

옵션 TOAD-DBA 모듈은 DBA 메뉴, Schema Browser 및 Create 메뉴에 

데이터베이스 관리 기능을 추가해 줍니다. TOAD-DBA 모듈 창에 대해서는 

TOAD 도움말에서 설명합니다. 

TOAD-DBA 창에는 다음이 들어 있습니다. 

Database Monitor 및 Unix Monitor ?  차트로 데이터베이스 성능을 

모니터링합니다. 

Instance Manager ?  액세스할 수 있는 데이터베이스의 상태를 검사합니다. 

Database Health Check ?  선택한 데이터베이스에 대해 검사를 수행하고 그 

결과를 표시합니다. 

Top Session Finder ?  리소스를 많이 사용하는 데이터베이스의 세션을 

찾습니다. 

Oracle Parameters ?  파라미터를 변경합니다. 

NLS(National Language Support) Parameters ?  세션, 인스턴스 및 



 - 62 - 

데이터베이스 파라미터 설정을 표시하고 파라미터를 변경합니다. 

Tablespace Map ?  데이터베이스의 테이블스페이스를 그래픽 형식으로 

봅니다. 

TOAD Control Files ?  컨트롤 파일을 표시합니다. 

Pinned Code ?  코드를 메모리 버퍼에 넣습니다. 

New Database Wizard ?  새 데이터 베이스를 만듭니다. 

Identify Space Deficits ?  다음 범위를 할당한 빈 디스크 공간이 부족한 

테이블을 표시합니다. 

Redo Log Manager ?  데이터베이스의 실행 취소 로그를 유지 관리합니다. 

Log Switch Frequency Map ?  데이터베이스가 로그 전환을 수행할 때 

표시됩니다. 

LogMiner ?  데이터베이스에서 문제를 유발한 시스템 변경 번호(SCN)를 

분석하여 문제 발생 이전 상태로 복원합니다. 

Export Utility Wizard ?  Virtual DBA 루틴을 사용하여 스키마 스크립트를 

내보냅니다. 

Import Utility Wizard ?  Virtual DBA 루틴을 사용하여 스키마 스크립트를 

가져옵니다. 

Generate Schema Script ?  선택한 스키마 또는 정의 파일을 사용하여 선택한 

모든 오브젝트에 대한 DDL 및 정의 파일을 생성합니다. 

Compare Schemas ?  이 기능의 DBA 버전은 def 파일을 로드하고 

마이그레이션/동기화 보고서를 스크립트 파일에 저장합니다. 

Unix Scheduler - 정기적으로 수행할 Unix 작업을 예약합니다. 

Unix and Windows Registry Parameters - 데이터베이스 성능을 향상시키기 

위해 Unix 및 Windows 레지스트리에 파라미터를 설정합니다. 

스키마 브라우저(Schema Browser) 

TOAD-DBA는 Schema Browser에 Dimensions, Directories, Libraries, 

Policies, Profiles, Roles, Rollback Segments 및 Tablespaces 등의 탭을 

추가합니다. 대부분의 탭에서는 관련 오브젝트를 작성, 변경, 드롭하고 세부 

사항을 볼 수 있으며, 추가 기능이 포함됩니다. 예를 들어, 테이블스페이스 및 

롤백 세그먼트를 온라인이나 오프라인으로 설정할 수 있습니다.  
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Create 메뉴 

TOAD-DBA는 Create 메뉴에 Dimensions, Directories, Libraries, 

Policy Definitions, Profiles, Roles, Rollback Segments 및 

Tablespaces 등의 메뉴 항목을 추가합니다.  


